Articulate Community Forums



Articulate Community Forums » Articulate Product Forums » Articulate Quizmaker » Moodle and QM - Attempts not registering???

 
 
LinkBack Thread Tools Search this Thread
Old 02-01-2011, 09:13 PM   # 1
Member
 
Join Date: Jan 2011
Posts: 76
Default Moodle and QM - Attempts not registering???


Hi

Thanks for you previous links, I've made some progress. Now the problem I'm having is that a user can have more attempts at a test than the specified maximum (which is currently set to two).

I logged in as a user, took the test the the FINISH. and for some reason I can keep attempting the test over and over.

I've watched all the tutorials in MoodleTuts.. but no luck.

What am I doing wrong?

I'm so close....but not quite there!

Also, a navigation bar appears after taking the test. this will confuse the quiz takers. What is it for and how do I remove it?

Thanks!

PS. I included a screenshot.
Attached Images
 
gilles007 is offline  
Old 02-02-2011, 08:27 AM   # 2
Member
 
Join Date: Nov 2009
Posts: 35
Default Re: Moodle and QM - Attempts not registering???


I'm not sure about your first problem, but about the navigation buttons, I think they won't appear if you set "Hide navigation buttons" to "Yes" in the SCORM settings.

I'm in the middle of testing Quizmaker in Moodle 2.0 myself, and I came across the same issue you mentioned before with the resume quiz. The way it functions seems counterintuitive so I ended up turning off the function... I wish there was some way to make the resume quiz function work the way it is supposed to.

Also, I wish there was some way to make Moodle count an aborted attempt as an attempt. As far as I can tell, it's only logged as an attempt if the user finishes the quiz. Any info on this?

Also, on a totally unrelated note, check out these Moodle modules. They are very useful for a course with a lot of SCORM content. (or any content, I suppose)

Collapsed Topics:
Moodle.org: Modules and plugins

Collapsed Weeks:
Moodle.org: Modules and plugins
loftmonkey is offline  
Old 02-02-2011, 09:19 AM   # 3
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


Thanks for this LM,

I'm literally pulling my hair out with this. I left a msg with my sales rep to hopefully speak to someone at Articulate about this.

LIke you, I really want/need to have the Resume function work correctly as this is a long quiz and need to be able to interrupt the quiz and resume at a later time.

I also need the grades to work correctly.

Let's hope I get some answers.

Thanks for the tip on the "hide nav" I'll give this a try. Looks like you found my prob. though.


Gilles
gilles007 is offline  
Old 02-02-2011, 09:21 AM   # 4
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


by the way loftmonkey,
do you have a method of clearly reporting detailed quiz results from Moodle? (instead of the non-formatted linear default way?)

Gilles
gilles007 is offline  
Old 02-02-2011, 09:49 AM   # 5
Moderator
 
Justin's Avatar
 
Join Date: Feb 2006
Posts: 8,995
Default Re: Moodle and QM - Attempts not registering???


Based on your screenshot, I would post this question in the moodle forums. You are asking about moodle functionality that isn't something we support.
__________________
Justin Wilcox
Customer Support Manager
Articulate - Empowering Rapid E-Learning
Tweet me here.
__________________
E-Learning Heroes, the new Articulate community site, is now available! Come join and check out the new forums, tutorials, downloads, and more!
Justin is offline  
Old 02-02-2011, 10:04 AM   # 6
Member
 
Join Date: Nov 2009
Posts: 35
Default Re: Moodle and QM - Attempts not registering???


Gilles,

If you are referring to itemized reporting of quiz results, unfortunately that's impossible. You can get: pass/fail, percentage, time started/finished, and number of attempts.

I guess this is how Articulate makes money on Articulate Online, their own LMS which interfaces perfectly with Articulate products and gives you itemized reports for all your questions (or so I read - I haven't tried it).
loftmonkey is offline  
Old 02-02-2011, 10:09 AM   # 7
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


Hi Justin,

I'm just looking for some instruction on how to publish my quiz correctly on Moodle. I have read many posts with other users experiencing challenges getting QM to behave properly in Moodle in terms of "resume", grading, complete/incomplete reporting, etc.

SInce Moodle is so popular, surely Articulate must have a doc somewhere describing how to configure both to work harmoniously together and "as expected".

Any thoughts?
Gilles
gilles007 is offline  
Old 02-02-2011, 10:10 AM   # 8
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


Thansk LM, that's what I thought.

Articulate Online was not an option due to cost for my client. They only have one quiz.

Gilles
gilles007 is offline  
Old 02-02-2011, 10:24 AM   # 9
Member
 
Join Date: Nov 2009
Posts: 35
Default Re: Moodle and QM - Attempts not registering???


As for your too many attempts allowed problem, have you tried setting "Force Completed" and/or "Force new attempt" to Yes?

I just tested it with both set to Yes, and it worked, although I'm not sure which one did the trick. When they were set to No, I have to check a "New attempt" box before clicking Enter in order for my attempt to be counted as a new attempt.

If no grades are being sent to your gradebook, the only time I had this problem was when I tried using SCORM 2004, which Moodle doesn't support yet.
loftmonkey is offline  
Old 02-02-2011, 10:31 AM   # 10
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


Thanks LM, I hadn't tried these 2 settings as I came across posts which stated to leave them to NO. I'll give it a try though.

when you tried this, did it still allow my user to "RESUME" a quiz? I hadn't tried it because I assumed it would prevent my users from Resuming (forced complete).

Thanks for helping me out.
G
gilles007 is offline  
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Articulate E-Learning Blogs


LinkBacks Enabled by vBSEO 3.1.0