Articulate Community Forums



Articulate Community Forums » Articulate Product Forums » Articulate Quizmaker » Moodle and QM - Attempts not registering???

 
 
LinkBack Thread Tools Search this Thread
Old 02-02-2011, 04:43 PM   # 21
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


Hi Beeneeb,

From the Moodle doc:
"Force completed

If enabled, the status of the current attempt is forced to "completed". This setting is only applicable to SCORM 1.2 packages. It is useful if the SCORM package does not handle revisiting an attempt correctly, in review or browse mode, or otherwise incorrectly issues the completion status."


Quesiton is: does the Articuate SCORM pkg handle revisiting an attempt correctly, in review or browse mode, or otherwise incorrectly issues the completion status?

Gilles
gilles007 is offline  
Old 02-02-2011, 04:53 PM   # 22
Moderator
 
Justin's Avatar
 
Join Date: Feb 2006
Posts: 8,995
Default Re: Moodle and QM - Attempts not registering???


That's still completely open to interpretation.
__________________
Justin Wilcox
Customer Support Manager
Articulate - Empowering Rapid E-Learning
Tweet me here.
__________________
E-Learning Heroes, the new Articulate community site, is now available! Come join and check out the new forums, tutorials, downloads, and more!
Justin is offline  
Old 02-02-2011, 05:39 PM   # 23
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


HI Justin,

I wasted another day on this. I've called my Articulate Sales rep again to see if this can be escalated.

loftmonkey: did you have any luck? I've tested all sorts of combinations/permutations and still not getting anywhere with the number of attempts and grading workign properly.
I'm curious to see if you found something.

I'm starting to wonder if I shouldn't have gone with Ispring's quiz solution....

Hmmmmm

Gilles
gilles007 is offline  
Old 02-02-2011, 09:37 PM   # 24
Member
 
Join Date: Mar 2010
Posts: 9
Default Re: Moodle and QM - Attempts not registering???


We are having major problems with QM quizzes not being recorded to moodle's lms.

I have actually logged in as some of the students; clicked on the scorm and it resumes at the last/results slide of the quiz showing their results, but those results are not in the grade book. I know the students are telling me the truth that they completed the quiz. The only way I can get the results into the grade book is to login as them and redo the quiz. On my computer (PC, Windows 7, Firefox browser) it records to the grade book.

I have checked with them and some are using MAC other PC; some on Explorer others Firefox or Safari.

My client's patience is wearing thin, and I don't blame them.

If this keeps up I will have no choice but to drop QM before my business is destroyed. Disappointing.
kevinfreeborn is offline  
Old 02-03-2011, 07:31 AM   # 25
Member
 
Join Date: Nov 2009
Posts: 35
Default Re: Moodle and QM - Attempts not registering???


In my testing I haven't had any problems with the grades being recorded in Moodle except when I tried using SCORM 2004 (which Moodle doesn't support yet). But now I'm freaked out because I haven't yet tried it with large numbers of users.

I assume it is more of a problem with Moodle though, as I used Quimaker successfully with over 1000 users on a different LMS for 20 weeks. Grades were recorded fine.
loftmonkey is offline  
Old 02-03-2011, 07:35 AM   # 26
Member
 
Join Date: Jan 2011
Posts: 76
Default Re: Moodle and QM - Attempts not registering???


Thanks, that's very encouraging.
I'll focus some more on the Moodle side of thing. i
Thanks
gilles007 is offline  
Old 02-03-2011, 07:43 AM   # 27
Member
 
Join Date: Nov 2009
Posts: 35
Default Re: Moodle and QM - Attempts not registering???


If I turn off the resume option in QM, the the resume dialog box doesn't pop up.

If I set force completed and force new attempt to YES, Moodle recognizes and logs each attempt as a new one without me having to check the new attempt box before clicking Enter.

The highest grade seems to be getting recorded properly in the gradebook.

I also set up completion tracking so that the quizzes are marked, on the Moodle course page, with a green check if passed, a red X if failed, and nothing if not yet attempted. This also seems to be working fine.

I haven't yet tested this with a large number of students so I'm a little worried that there might be problems like kevinfreeborn mentioned.
loftmonkey is offline  
Old 02-03-2011, 08:24 AM   # 28
Moderator
 
Justin's Avatar
 
Join Date: Feb 2006
Posts: 8,995
Default Re: Moodle and QM - Attempts not registering???


Quote:
Originally Posted by gilles007 View Post
HI Justin,

I wasted another day on this. I've called my Articulate Sales rep again to see if this can be escalated.

loftmonkey: did you have any luck? I've tested all sorts of combinations/permutations and still not getting anywhere with the number of attempts and grading workign properly.
I'm curious to see if you found something.

I'm starting to wonder if I shouldn't have gone with Ispring's quiz solution....

Hmmmmm

Gilles
Unfortunately, your issues are on the moodle side of things, not on the content side of things so we woudln't really be able to offer anything beyond what Brian and I have already suggested. I would encourage you to submit your issue to the moodle forums and see if they can help there. We don't support third party LMS.
__________________
Justin Wilcox
Customer Support Manager
Articulate - Empowering Rapid E-Learning
Tweet me here.
__________________
E-Learning Heroes, the new Articulate community site, is now available! Come join and check out the new forums, tutorials, downloads, and more!
Justin is offline  
Old 02-03-2011, 08:27 AM   # 29
Moderator
 
Justin's Avatar
 
Join Date: Feb 2006
Posts: 8,995
Default Re: Moodle and QM - Attempts not registering???


Quote:
Originally Posted by kevinfreeborn View Post
We are having major problems with QM quizzes not being recorded to moodle's lms.

I have actually logged in as some of the students; clicked on the scorm and it resumes at the last/results slide of the quiz showing their results, but those results are not in the grade book. I know the students are telling me the truth that they completed the quiz. The only way I can get the results into the grade book is to login as them and redo the quiz. On my computer (PC, Windows 7, Firefox browser) it records to the grade book.

I have checked with them and some are using MAC other PC; some on Explorer others Firefox or Safari.

My client's patience is wearing thin, and I don't blame them.

If this keeps up I will have no choice but to drop QM before my business is destroyed. Disappointing.
What standard are you publishing for? Have you checked out these articles?
Upload and track a Quizmaker ’09 Quiz in Moodle
Getting Your Own LMS – Part 4 Moodle - Dave Moxon's Articulate eLearning Blog
__________________
Justin Wilcox
Customer Support Manager
Articulate - Empowering Rapid E-Learning
Tweet me here.
__________________
E-Learning Heroes, the new Articulate community site, is now available! Come join and check out the new forums, tutorials, downloads, and more!
Justin is offline  
Old 02-03-2011, 11:48 AM   # 30
Member
 
Join Date: Mar 2010
Posts: 9
Default Re: Moodle and QM - Attempts not registering???


Quote:
Originally Posted by loftmonkey View Post
If I turn off the resume option in QM, the the resume dialog box doesn't pop up.

If I set force completed and force new attempt to YES, Moodle recognizes and logs each attempt as a new one without me having to check the new attempt box before clicking Enter.

The highest grade seems to be getting recorded properly in the gradebook.

I also set up completion tracking so that the quizzes are marked, on the Moodle course page, with a green check if passed, a red X if failed, and nothing if not yet attempted. This also seems to be working fine.

I haven't yet tested this with a large number of students so I'm a little worried that there might be problems like kevinfreeborn mentioned.
Thanks for the suggestions. Can you show a pic of the setting you are referring to (i.e. force completed, and force new attempt). I do not see these in my moodle settings?
kevinfreeborn is offline  
 


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




Articulate E-Learning Blogs


LinkBacks Enabled by vBSEO 3.1.0